Australia - Delivery Delays towards Telstra Network

Incident Report for ClickSend Service Status

Resolved

This incident has been resolved.
Posted Nov 29, 2024 - 04:10 UTC

Monitoring

We are continuing to monitor for any further issues.
Posted Nov 29, 2024 - 02:40 UTC

Identified

A fix has been implemented and we are monitoring the results.
Posted Nov 29, 2024 - 02:39 UTC

Investigating

We have identified an issue on the Telstra network where SMS delivery to Telstra handsets appears to be delayed. We are awaiting feedback from Telstra. Other carriers are not affected.
Posted Nov 29, 2024 - 01:05 UTC
This incident affected: Products (SMS).