Network Issue in Australia (Telstra)

Incident Report for ClickSend Service Status

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 23:58 UTC

Update

We are continuing to investigate this issue.
Posted Jul 09, 2026 - 00:52 UTC

Update

We are continuing to investigate this issue.
Posted Jul 08, 2026 - 08:02 UTC

Investigating

We are currently observing delivery issues in Australia - Telstra

Telstra has issued the following statement regarding the outage: "We’re looking into an issue affecting some mobile calls and data connections. If you’re having trouble connecting at first, try again as it may work on a retry. We’re on it and will share an update as soon as it’s fixed. Thanks for bearing with us."

We are closely monitoring the situation on our end and will provide another update as soon as Telstra resolves the issue.
Posted Jul 08, 2026 - 02:00 UTC
This incident affected: Products (SMS, MMS).