Intermittent voice call delivery issues for Spain, Mexico, Philippines & the UK.
Incident Report for ClickSend Service Status
Resolved
This issue appears to be resolved. We'll investigate further to ensure this doesn't happen again.
Posted Jun 28, 2021 - 02:18 UTC
Investigating
Some users are currently experiencing issues sending voice calls to the following countries: Spain, Mexico, Philippines & the UK. We're currently investigating the issue.
Posted Jun 25, 2021 - 12:36 UTC
This incident affected: Products (Voice).