Email Delays

Incident Report for ClickSend Service Status

Resolved

This issue is now resolved.
Posted Oct 14, 2020 - 05:21 UTC

Investigating

Some customers are experiencing Email Marketing and Transactional Email delays. We're working to resolve the issue urgently.
Posted Oct 14, 2020 - 04:57 UTC
This incident affected: Products (Email).