USA Toll free number delivery issue
Incident Report for ClickSend Status
Resolved
This issue is now resolved. The cause was a network error. We're working with the network to find out what caused the issue and make sure it doesn't happen again. All messages have been resent. No messages were lost.
Posted Sep 25, 2020 - 15:28 UTC
Identified
Some customers are experiencing SMS delivery issues when sending from Toll Free Numbers. We're working to resolve the issue urgently and will queue and deliver traffic once the issue is resolved.
Posted Sep 25, 2020 - 13:45 UTC
This incident affected: Products (SMS).