Certificate error affecting some services
Incident Report for ClickSend Service Status
Postmortem

This issue has been tracked to a Comodo SSL certificate issue. We’ve revoked the certificate and issued new certificates. Procedures will be put in place to ensure this never happens again.

Posted May 30, 2020 - 13:36 UTC

Resolved
This issue has been resolved. We're investigating the reason for the certificate issue. More details will be provided.
Posted May 30, 2020 - 13:35 UTC
Update
We are continuing to investigate this issue.
Posted May 30, 2020 - 13:31 UTC
Update
We are continuing to investigate this issue.
Posted May 30, 2020 - 12:43 UTC
Update
We are continuing to investigate this issue.
Posted May 30, 2020 - 12:43 UTC
Update
We are continuing to investigate this issue.
Posted May 30, 2020 - 12:31 UTC
Investigating
We are currently investigating this issue.
Posted May 30, 2020 - 12:30 UTC
This incident affected: Services (REST API, HTTP API, SMPP).