Inbound fax issues
Incident Report for ClickSend Service Status
Resolved
The issue affecting inbound fax delays for some customers has been resolved. We're working with the number provider to identify the exact cause of the delays and will put measures in place to ensure this doesn't happen again.
Posted Mar 25, 2022 - 06:38 UTC
Monitoring
Some customers are experiencing inbound fax issues. We've identified the issue and are working with the number provider to resolve it. No inbound faxes will be lost. Once the issue is resolved, all held inbound faxes will be delivered.
Posted Mar 24, 2022 - 15:00 UTC
This incident affected: Products (Fax).