Email delivery issues
Incident Report for ClickSend Status
Resolved
This issue is now resolved.
Posted Sep 24, 2020 - 12:10 UTC
Identified
Our Email Marketing and Transactional Email products are currently seeing low delivery rates. This is due to some IPs being listed as spam. We're currently sourcing new IP addresses to put into our pool. This issue should be resolved shortly.
Posted Sep 24, 2020 - 10:53 UTC
This incident affected: Products (Email).