Transactional and Marketing emails delivery issue
Incident Report for ClickSend Service Status
Resolved
This incident has been resolved.
Posted Jun 20, 2023 - 12:22 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 20, 2023 - 06:33 UTC
Identified
ClickSend are working with our downstream email provider to resolve an issue with Email Delivery impacting our Email Marketing and Transactional Email platform. All emails that are submitted to our gateway remain queued and will be delivered as soon as the email provider is able to correct the error. We are unable to cancel any emails that have already been submitted to our gateway.
Posted Jun 19, 2023 - 14:17 UTC
This incident affected: Products (Email).