Credit card transaction issues
Incident Report for ClickSend Service Status
Resolved
This issue has now been resolved, no issues have been experienced for the past hour.
Posted Feb 24, 2020 - 05:22 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 24, 2020 - 01:21 UTC
Identified
We’re currently experiencing issues processing credit card payments due to our upstream credit card processing gateway. All automatic recharges will be retried when the issue is resolved. One off payments will return errors.
Posted Feb 24, 2020 - 01:17 UTC
This incident affected: Other (Credit Card Payments).