Delay with receiving and processing Delivery Receipts.
Incident Report for ClickSend Service Status
Resolved
No further incoming delays have been detected during the past 7 hours.
We believe this incident has now been resolved.
Please reach out to us via our dashboard if you do experience any messaging issues.
Posted Jun 24, 2022 - 07:19 UTC
Update
Delivery Receipts appear to be fixed as there were no further occurrences the past 15 hours.

Isolated instances of delayed inbound messages are still seen. The delays are not greater than 15minutes.

We are continuing our investigation into this and will update you as soon as more information becomes available.
Posted Jun 24, 2022 - 00:41 UTC
Update
We have implemented more changes that have prevented any further occurrences of failed Delivery Receipt and isolated instances of delayed inbound messages.

This indicates to us that the Incident should now be resolved.
We will continue to monitor this closely and post an update if any new information becomes available.

This Incident will be closed off within the next 24 hours if no further occurrences are seen.
Posted Jun 23, 2022 - 08:25 UTC
Update
We have detected more occurrences of delayed Delivery Receipts during the past 15 hours, and isolated instances of delayed inbound messages.

All delays are no more than 15mins.

We are continuing to investigate the cause of these issues and will provide an update within the next 4 hours.
Posted Jun 23, 2022 - 01:37 UTC
Update
We have implemented more changes that have prevented any further occurrences of failed Delivery Receipt since 6:00 AEST.

This indicates to us that the Incident should now be resolved.
We will continue to monitor this closely and post an update if any new information becomes available.

This Incident will be closed off within the next 24 hours if no further occurrences are seen.
Posted Jun 22, 2022 - 04:53 UTC
Update
We are still seeing isolated occurrences of the Delivery Receipt delay.

There is no impact on sending and receiving messages, but we are continuing to investigate the issue and identify the root cause and implement a permanent fix.

We will provide another update in 4hrs
Posted Jun 22, 2022 - 00:38 UTC
Update
ClickSend have seen no further interruption or delays to Delivery Receipts.

We will monitor for the next 24hrs before we close this incident.
Posted Jun 21, 2022 - 07:50 UTC
Update
ClickSend implemented a change to infrastructure that appears to have resolved the issue.

We have not seen any further Delivery Receipt delays since 12:10pm (AEST).

We will continue to monitor the issue, and provide further updates if we notice any further recurrence.
Posted Jun 21, 2022 - 05:48 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 21, 2022 - 05:47 UTC
Monitoring
ClickSend is investigating a delay with receiving and processing Delivery Receipts into our Dashboard and out to associated Webhooks.
This is not impacting SMS deliverability, and is only affecting SMS to Australia, New Zealand and the US. The maximum delay is 15mins, and the impact is intermittent, so not affecting all receipts.
ClickSend will continue to investigate and update this incident when we have more information.
Posted Jun 21, 2022 - 02:07 UTC
This incident affected: Products (SMS) and Services (REST API, HTTP API, SMPP, Email to SMS, Webhooks).