Incident Name: Fax service down
Incident Report for ClickSend Service Status
Resolved
The issue was identified, and we are working with the Carrier's support team. We have fixed the issue now. All pending Faxes have been sent now.
Posted Nov 17, 2022 - 01:56 UTC
Investigating
Our Fax service is currently down, we are investigating the issue.
Posted Nov 17, 2022 - 01:33 UTC
This incident affected: Products (Fax).