Global Network experiencing issues

Incident Report for ClickSend Service Status

Resolved

The following services are now operational:
• Online Dashboard
• REST API

We are continuing to monitor performance to ensure stability.
Posted Nov 18, 2025 - 12:39 UTC

Investigating

We are aware of, and investigating an issue which impacts multiple customers: Widespread 500 errors, Dashboard and API also failing.
We are working to understand the full impact and mitigate this problem. More updates to follow shortly
Posted Nov 18, 2025 - 12:12 UTC
This incident affected: Services (Online Dashboard, REST API, HTTP API).