Telstra SMS Issue

Incident Report for ClickSend Service Status

Resolved

This incident has been resolved, please let us know if you encounter any issues
Posted Feb 09, 2026 - 05:47 UTC

Monitoring

New messages should now work, previously sent messages will likely be delayed

Are you Impacted by signing into ClickSend Dashboard?
Workaround: Select the Email Verification option instead of SMS

New Customer?
Please reach out to our Chat Support or send an email to support@clicksend.com
Posted Feb 09, 2026 - 03:09 UTC

Investigating

New messages should now work, previously sent messages will likely be delayed

Are you Impacted by signing into ClickSend Dashboard?
Workaround: Select the Email Verification option instead of SMS

New Customer?
Please reach out to our Chat Support or send an email to support@clicksend.com
Posted Feb 09, 2026 - 02:23 UTC
This incident affected: Products (SMS) and Services (Online Dashboard).