We are currently experiencing an incident service affecting SMS & MMS Campaigns functionality. Users may not be able send SMS & MMS campaigns through the dashboard or API. We're also experiencing dashboard issues that is showing the old UI.

Incident Report for ClickSend Service Status

Resolved

The issues has been successfully resolved, and both SMS and MMS campaign services are now fully operational, as well as the login to the dashboard. If you continue to experience any issues, please don’t hesitate to contact our chat support for further assistance.
Posted Oct 20, 2025 - 22:49 UTC

Update

The issues has been successfully resolved, and both SMS and MMS campaign services are now fully operational, as well as the login to the dashboard. If you continue to experience any issues, please don’t hesitate to contact our chat support for further assistance.
Posted Oct 20, 2025 - 22:22 UTC

Update

The issues has been successfully resolved, and both SMS and MMS campaign services are now fully operational, as well as the login to the dashboard. If you continue to experience any issues, please don’t hesitate to contact our chat support for further assistance.
Posted Oct 20, 2025 - 19:10 UTC

Investigating

The issues has been successfully resolved, and both SMS and MMS campaign services are now fully operational, as well as the login to the dashboard. If you continue to experience any issues, please don’t hesitate to contact our chat support for further assistance.
Posted Oct 20, 2025 - 18:30 UTC
This incident affected: Products (SMS, MMS) and Services (Online Dashboard).