Unable to Receive Activation Token
Incident Report for ClickSend Service Status
Resolved
This incident has been resolved now.
Posted Jan 24, 2024 - 23:14 UTC
Update
We are continuing to investigate this issue.
Posted Jan 24, 2024 - 23:13 UTC
Investigating
We are currently investigating this issue.
Posted Jan 24, 2024 - 15:57 UTC
This incident affected: Services (Online Dashboard).