Chat Support Delay Issue

Incident Report for ClickSend Service Status

Resolved

This incident has been resolved.
Posted Feb 11, 2025 - 22:49 UTC

Investigating

We are having issues with our chat platform; we may not be responsive or able to provide service support immediately.

Please bear with us for this short period; we will update our status page once this is resolved. Alternatively, you can send an email to support@clicksend.com.
Posted Feb 11, 2025 - 22:39 UTC
This incident affected: Services (Online Dashboard).