Email Marketing Delays
Incident Report for ClickSend Status
Resolved
This incident has been resolved.
Posted Oct 30, 2020 - 01:08 UTC
Investigating
We are currently investigating the issue.
Posted Oct 30, 2020 - 00:43 UTC
This incident affected: Products (Email).