Inbound fax delays - Australia
Incident Report for ClickSend Service Status
Postmortem

Our number provider has identified and fixed a bug that caused this issue. We’ll also work with them to ensure monitoring is setup to identify issues like this quicker.

Posted Mar 29, 2022 - 02:50 UTC

Resolved
Inbound faxes to Australian numbers were delayed. No faxes have been lost. We're working with our number provider to ensure this issue is permanently resolved and doesn't happen again.
Posted Mar 27, 2022 - 16:00 UTC