ClickSend Dashboard and API
Incident Report for ClickSend Service Status
Resolved
This incident has been resolved.
Posted Nov 24, 2023 - 19:58 UTC
Investigating
We regret to inform you that the ClickSend dashboard and API have experienced degraded performance, which may affected the ClickSend services you use. Our technical team is currently fixing it.

We apologize for any inconvenience this may have caused, and we appreciate your patience. We strongly recommend you subscribe to our status page to get the latest updates. https://status.clicksend.com/#
Posted Nov 24, 2023 - 14:40 UTC
This incident affected: Services (Online Dashboard, REST API).