EU Posts Delayed – Essential Maintenance

Incident Report for ClickSend Service Status

Update

We are continuing to investigate this issue.
Posted Sep 03, 2026 - 01:34 UTC

Investigating

Our vendor in the EU region is currently performing essential maintenance, which is causing delays to postal services in the region.

All ClickSend systems are operating normally, and any letters/postcards submitted by customers have been successfully received and are securely held within our system. However, there may be a delay in forwarding these to our EU vendor while the maintenance is ongoing.

We are monitoring the situation and will provide further updates as they become available.
Posted Sep 03, 2026 - 01:24 UTC
This incident affects: Products (Letters, Postcards).