Dashboard Issues: MMS/Letters/Postcard

Incident Report for ClickSend Service Status

Resolved

This issue is now resolved.
Posted Feb 17, 2021 - 14:18 UTC

Identified

Some customers are currently getting errors when trying to send MMS/postcards/letters via the dashboard. The issue has been identified and will be resolved ASAP.
Posted Feb 17, 2021 - 14:15 UTC
This incident affected: Services (Online Dashboard).