UK Outage/Connection Issues - formerly Dashboard Outage (UK Customers)

Incident Report for ClickSend Service Status

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 10:11 UTC

Monitoring

ISP's like 'Sky' seem to have fixed their routing issue to our Datacentre, we are getting confirmation from customers to confirm if the issue is resolved
Posted Dec 09, 2025 - 07:08 UTC

Investigating

We are aware of connection issues from UK ISPs (including Sky & BT Openreach) to our AWS cloud regional datacenter leading to errors when customers try to log in or access our platform. We have escalated this to AWS.
Posted Dec 08, 2025 - 11:21 UTC
This incident affected: Services (Online Dashboard).