SMS and MMS Delays
Incident Report for ClickSend Service Status
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 04:06 UTC
Investigating
We are currently seeing SMS and MMS delays with US traffic. Our team is actively working to resolve the issue, and we apologize for any inconvenience this may cause. Thank you for your patience and understanding. We strongly recommend you subscribe to our status page to get latest updates: https://status.clicksend.com/#
Posted Mar 05, 2024 - 01:56 UTC
This incident affected: Products (SMS, MMS).