Sender ID and Dedicated Number Issue

Incident Report for ClickSend Service Status

Resolved

This incident has been resolved.
Posted Jul 23, 2025 - 02:22 UTC

Monitoring

Issues appear to have ceased and we are monitoring the situation
Posted Jul 22, 2025 - 03:04 UTC

Investigating

We are currently investigating reports of unexpected behavior involving Sender IDs and dedicated numbers. Our technical team is actively assessing the root cause and working to resolve the issue as quickly as possible.

We will continue to provide updates as more information becomes available. We appreciate your patience and understanding while we work to restore full functionality.
Posted Jul 22, 2025 - 01:58 UTC
This incident affected: Products (SMS).