Recharges not working

Incident Report for ClickSend Service Status

Resolved

The issue is now resolved.
Posted Apr 24, 2023 - 04:07 UTC

Investigating

Our recharges are currently not working, we are investigating the issue, will keep you posted. We strongly recommend you subscribe to our status page to get latest updates https://status.clicksend.com/#
Posted Apr 24, 2023 - 03:40 UTC
This incident affected: Services (Online Dashboard).