Marketing & Transactional email service are down.
Incident Report for ClickSend Service Status
Resolved
This incident has been resolved.
Posted Jul 21, 2023 - 12:24 UTC
Update
We are continuing to investigate this issue.
Posted Jul 20, 2023 - 12:33 UTC
Update
We are continuing to investigate this issue.
Posted Jul 20, 2023 - 12:32 UTC
Investigating
ClickSend are working with our downstream email provider to resolve an issue with Email delivery impacting our Email Marketing and Transactional Email platform
Posted Jul 20, 2023 - 12:31 UTC
This incident affected: Products (Email).