Dashboard is Temporary Unavailable
Incident Report for ClickSend Service Status
Resolved
This incident has been resolved.
Posted Jul 31, 2023 - 01:48 UTC
Monitoring
A fix has been implemented to resolve the issue. We will continue to monitor this incident.
Posted Jul 31, 2023 - 01:24 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 31, 2023 - 01:23 UTC
Investigating
We are investigating this issue and working to resolve it as soon as possible. We apologize for any inconvenience.
Posted Jul 31, 2023 - 00:33 UTC
This incident affected: Services (Online Dashboard).