Outbound fax delays
Incident Report for ClickSend Status
Resolved
This issue is now resolved. All queued faxes have been delivered.
Posted May 31, 2020 - 07:46 UTC
Identified
We've identified outbound fax delays affecting some customers. The cause is an invalid SSL certificate on one of our upstream carriers. All faxes will be queued and delivered once the issue is resolved.
Posted May 31, 2020 - 02:55 UTC
This incident affected: Products (Fax).